2011年09月28日 70条评论

升级到 Firefox 7,遭遇“XML解析错误:未定义的实体”错误及解决方法

今天一大早就把 Firefox 6.02 升级 Firefox 7,升级后就提示有3个扩展不支持,于是我安装了 Add-on Compatibility Reporter 这个扩展来关闭 Firefox 的兼容性检查功能。重启 Firefox,进扩展看到升级完 FF 后不兼容的扩展提示重启,于是再次重启 Firefox 7,问题来了,Firefox 7 出现一个黄色窗口提示“XML解析错误:未定义的实体”……囧rz

这个肯定是强制兼容导致的,但不知道是哪个扩展,只好进用户配置文件夹一个一个移出测试

附用户配置文件夹位置:
XP C:\Documents and Settings\[User Name]\Application Data\Mozilla\Firefox\Profiles\xxxxxxxx.default\
Vista/Win7 C:\Users\[user name]\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default\

把 extensions 目录里面的扩展一个一个移出此目录测试,最后发现是 langpack-zh-CN@firefox.mozilla.org.xpi 导致的,删除即可解决。

又多了一个问题解决方法,最近老是碰到一些蛋疼的、简单又折腾人的小问题,文囧厉害也只好写写这类小问题的文章了……

zww
or
oooo

“升级到 Firefox 7,遭遇“XML解析错误:未定义的实体”错误及解决方法”有70条评论

  1. schiy says:

    抢到没有? :lol:

    1. schiy says:

      @schiy
      刚才真是惊险,没看文章就直接抢沙发了,罪过啊~~
      话说好久没用FF了呢。

    2. zwwooooo says:

      @schiy
      平时用Chrome的确速度点

  2. phoetry says:

    fx我都懒得更新了, 实在是...人家chrome更新是按时间来定版本号的, fx却是没啥改动就跳个版本号=_=
    边说边打开fx, 它自己开始自动更新了...

    1. phoetry says:

      @phoetry
      坑爹啊, 我本来是6.0, 然后自动更新下载了16M的东西后变成了6.02, 然后现在又在自动更新, 又要下载6.4M的东西...

    2. phoetry says:

      @phoetry
      经过两次自动更新终于成功7.0了, 扩展全部活着, Yeah
      (因为只有开发者相关扩展...)

    3. zwwooooo says:

      @phoetry
      囧rz,竟然不能直接升级到7?好蛋疼的方式……

  3. 没有必要关闭兼容性检查吧。我的经验是不兼容的插件,找到其安装.xpi文件,再拖到FF里重新安装下就好了。

    1. zwwooooo says:

      @阅微博客
      这样行么?

  4. Louis Han says:

    也算是重大贡献了

    1. zwwooooo says:

      @Louis Han
      厄,竟然用“重大”,不敢当

  5. 三石头 says:

    刚刚升了级,似乎感觉响应速度变快了,插件全部通过 :mrgreen:

    1. zwwooooo says:

      @三石头
      还没认真用,别只是版本升级就好了

    2. @三石头
      用火狐的都是好同志

    3. zwwooooo says:

      @软件风暴
      调试网站还是ff好

  6. Iecho says:

    呵呵!一直在用chrome

    1. zwwooooo says:

      @Iecho
      个人喜好或者需求吧

  7. s5s5 says:

    快换CHROME吧 :mrgreen:

    1. zwwooooo says:

      @s5s5
      Chrome平时切换用,单用Chrome对我不适合。

  8. dee says:

    在看这篇文章的时候,我打开了FF然后让他自动升级了,升级完了就关了。 :evil:
    现在除非我用到某些特定功能的时候才会用FireFox.日常浏览就用Chrome了。

    1. zwwooooo says:

      @dee
      我不折腾时就可以用Chrome

  9. 额。。还没来得及升级额,你就折腾了!

    1. zwwooooo says:

      @蓝色离子
      我是升级了才遇到问题嘛

  10. 够蛋疼啊 tete版也发布了

    1. zwwooooo says:

      @软件风暴
      tete也是很速度的

  11. zee says:

    用的旧版

  12. 秦天SEO says:

    看到标题猜到是语言文件的问题,果然 :grin:

    1. zwwooooo says:

      @秦天SEO
      呵呵,小问题

  13. 寒意 says:

    我的迅雷组件在FF6上就不支持了……不知道迅雷什么时候更新~

    1. zwwooooo says:

      @寒意
      我不需要这个,哈

  14. wmtimes says:

    让你升级这么快。 :grin:

    1. zwwooooo says:

      @wmtimes
      正式版就升升吧

    2. wmtimes says:

      @zwwooooo
      我也升了。不过还好。我这次回来是来要链接的。友链。 :mrgreen:

    3. zwwooooo says:

      @wmtimes
      哈,我这停止友链差不多2年了吧,见谅。

  15. SErHo says:

    比较坑爹的是,下载都要连VPN,不然直接跳到中国版,下载带有浓郁中国特色的产品。

    1. zwwooooo says:

      @SErHo
      去英文网站下载

  16. zhx says:

    FF升级的够快的~~

    1. zwwooooo says:

      @zhx
      感觉只在升版本号,orz

  17. 升级控啊,有新的就升?

    1. zwwooooo says:

      @yesureadmin
      nonono,正式版升级才升

  18. Alex Gao says:

    我前一阵子一直在chrome和ff之间徘徊,chrome我现在发现真的不好用,标签开多了容易假死,一死一片。但ff有个问题,就是自带的同步功能很蛋疼,经常书签同步不全,不过升级到7以后貌似书签同步正常点了,但愿不是错觉,阿门!

    1. zwwooooo says:

      @Alex Gao
      用Xmarks,FF/Chrome同步,嘿嘿

    2. Alex Gao says:

      @zwwooooo
      ff下的xmarks也是老是出问题,同步不完整

    3. zwwooooo says:

      @Alex Gao
      我只同步书签而已,木有问题。

  19. 王铁柱 says:

    刚好相反,Firefox切换用,平时用Chrome. :idea:

    1. zwwooooo says:

      @王铁柱
      霍霍,各有所需/喜好

  20. 张扬扬 says:

    刚才看了下日志,现在是不是都有firefox 9了

    1. zwwooooo says:

      @张扬扬
      有,但不是正式版

发表评论

昵称 *

网址

B em del U Link Code Quote