2010年10月12日 160条评论

Firefox每打开一个网站就假死一下的原因

最近我在 W7 使用 Firefox 遇到了一个非常让人恼火和纠结的问题。

表现

每打开一个网站就假死5~7秒!  如果同时打开多个网站那是10几秒不能动蛋!

XP 下的 Firefxo 没有此问题,上个月头 W7 下也没有问题。

尝试查找原因

我期间重装了 Firefox 两次,同样卡你没商量。

没装任何插件也试过 ,一样无法解决。

乱猜疑

1. 曾经怀疑过是用来升级系统的 360 安全卫士搞的鬼,但非常失望,不是!

2. 怀疑 Windows7 的系统问题 ,但不管我怎么查毒、查木马都没有什么发现,检测系统也没发现什么问题!

3. 胡思乱想:我的 RPWT!

无奈

暂时放弃 Firefox ,转主用 Chrome,但还是不耐用,于是前几天拜托 A-shun 定制一个 Opera 10.70 用(前天的文章已经说过,这里再感谢下)

爆发

昨天我要折腾主题,调试主题非 Firefox 莫属!调试了半个小时主题,我终于忍不住了,我要发疯了,不找出原因誓不罢休!

疯狂查找原因

1. 疯狂搜索,没有结果

2.  疯狂xx,疯了。

暴风雨后的冷静

狂吼后冷静下来,喝杯茶,突然脑经灵光一闪,一打开网站就卡,是不是 DNS 的问题?其他浏览器没问题那么就是 FF 本身的 DNS 问题了?本身的 DNS 影响最大的就是代理服务器设置问题,我的妈啊,竟然没去看过 FF 的代理服务器设置!!!

如下图

没问题啊,默认设置,不过跟系统设置 一致就是跟ie的一样了,于是打开ie的代理服务器设置,一看吓一跳,问题水落石出!

原来是我前段时间用了一段时间 Chrome 造成的,众所周知 Chrome 是通过修改 ie 代理设置实现代理的,而我用了自动代理插件,所以导致修改了ie代理服务器的自动代理脚本。囧~

解决办法

看下图吧,唉,低级错误~

郁闷了我大半个月,我撞墙去~

zww
or
oooo

“Firefox每打开一个网站就假死一下的原因”有160条评论

  1. 久酷 says:

    ......... :lol: :lol: 没事自己找乐嘛 :mrgreen: :mrgreen:

    1. zwwooooo says:

      @久酷
      文囧~不过这个问题的确让我郁闷了很久

  2. 小闇 says:

    裝過很多插件之後全刪了速度依然悲劇

    1. zwwooooo says:

      @小闇
      主要是开启速度慢点,正常的ff其他方面速度也可以

  3. 小邪 says:

    ╮(╯▽╰)╭ Chrome的地址栏看不到http://,怨念啊 。。。
    有种换FF的冲动起来鸟 。。

    1. zwwooooo says:

      @小邪
      这的确很不爽,Google的做法通常让你很郁闷:不给你选择,你只能按照它的意思用,加个选项会死么?囧~

    2. max says:

      @小邪
      哈哈,这个我也很不惯~

  4. logicmd says:

    用FF居然不用FoxyProxy啊,那个很好用,可以避免楼主问题 :razz:

    1. zwwooooo says:

      @logicmd
      你搞错了,这个跟ff的代理插件没关系,即使我开了autoproxy也一样:不用代理的网站ff会去找本身代理设置,而我的ff因为文章所说原因会去调用ie里面的auto脚本,从而导致问题。

    2. logicmd says:

      可以看出你肯定没用过FoxyProxy,最多用过autoproxy, FoxyProxy会接管Firefox里面的代理设置,就算那样设只要FoxyProxy正确就不会影响~

    3. zwwooooo says:

      我通常够用就好,不喜欢试用各种插件,所以没用过FoxyProxy也是正常的。

  5. zrqx008 says:

    还真是粗心…

    1. zwwooooo says:

      @zrqx008
      因为平时一般不用ie

  6. 七七 says:

    唉,速度也很慢,看来得好好查查!

  7. A.shun says:

    = =囧
    难道你不用autoproxy么

    这个应该叫做等待连接什么的,代理服务器线程限制
    假死应该是浏览器ui或进程无响应之类的问题

    1. A.shun says:

      @A.shun
      其实这个应该是chrome造成的杯具- -
      没有自己的代理机制,离不开IE的浏览器

    2. zwwooooo says:

      @A.shun
      我在4楼说明了,跟插件没关系,本地网站就会-》ff的代理设置(设置为系统时)-》ie的代理设置,而auto脚本导致ff dns查找问题

  8. fblue says:

    晕,一开始还真想不到这个。。
    ps,换邮箱了,之前那个怎么都收不到回复。。。

    1. zwwooooo says:

      @fblue
      貌似雅虎的收不到

  9. 万戈 says:

    说明大叔两次重装卸载不彻底啊,要把这些注册表也删了,那是绝对的重装~
    另外,疯狂xx,求图 :mrgreen:

    1. zwwooooo says:

      @万戈
      跟这个没关系,因为ff装好后默认的代理设置就是我文章图片所示:使用系统代理设置,而我忽略了ie给chrome改了代理设置

  10. mice says:

    :mrgreen: 跟万戈一样求图..

    1. zwwooooo says:

      @mice
      自己随便yy :evil:

  11. 1QiQiBoY says:

    这是一个乌龙事件。。 :shock:

    1. zwwooooo says:

      @QiQiBoY
      也跟太少用ie有关系

  12. W7+FF没有问题啊,只是有Flash的地方可能会卡一下(原因是FF的插件防崩溃机制)

    1. zwwooooo says:

      @星野苍真
      这是个“忽略”造成的时间

  13. 木本无心 says:

    哈,Firefox和chrome相比,远去了。

    1. zwwooooo says:

      @木本无心
      看什么地方比了,不能单单用速度来比

  14. 三人行 says:

    了解,呵呵

  15. max says:

    我的FF 3.6.10在win7下唯独打开Gmail网页时会卡一会,泣。。。

    1. zwwooooo says:

      @max
      是不是js处理速度问题

    2. max says:

      @zwwooooo
      可能吧,不过只会在打开Gmail时才会,其他网页倒没有这种情况。

  16. 逝魂 says:

    解决方法很简单啊

    1. zwwooooo says:

      @逝魂
      因为是“忽略”造成的

  17. 流年 says:

    FF也需要翻,我使用自动代理,配合AutoProxy;
    删除肯定是不彻底,像我上次,连配置文件都完全删了,最后还清理注册表

    1. zwwooooo says:

      @流年
      跟配置文件没关系,我的就是ff默认配置+chrome修改了ie代理设置造成的,autoproxy我也用了,具体看4楼、7楼我的回复

  18. Leyeang says:

    :sad: 昨晚电脑一停一停的仿佛电压不稳般启动不了,急的难受,折腾一个小时,莫名其妙的就启动了。

    估计感受差不多,一样是莫不着头脑找不着原因……
    还在撞墙中

    1. zwwooooo says:

      @Leyeang
      从简单的找起,或许会更快找到问题所在,哈哈

  19. 竹下无为梦 says:

    弄好就行了。

  20. 阿修 says:

    同样的状况,我是Chrome下发生的~~至今无解啊

    1. @阿修
      不是假死,就是要很久才能开始连接。

    2. zwwooooo says:

      @阿修
      看看是否也是代理造成的,哈哈

发表评论

昵称 *

网址

B em del U Link Code Quote