2010年08月19日 184条评论

WP插件: Disable Revisions and Autosave

2010.8.29 Update:使用此插件会出现一个郁闷的问题,具体原因和解决方法到此《使用Disable Revisions and Autosave出现的问题

》以前WP2.7/2.8时代都是手动禁止WordPress的修订版本和自动保存的鸡膊功能,后来由于嫌麻烦,就用超级开关(Super Switch)这个插件来实现。

几天前我升级到WordPress 3.0.1后,发现这几天写的文章ID不连续了,跳的厉害:25240-》25249-》25254,本来以前在yo2.cn时就是因为不知道这个问题导致我的ID已经高到上2万多了,现在再这样跳可不行。

》检查一下,原来是超级开关(Super Switch)插件失效鸟~(这个插件很奇怪,在一些WP2.9也会无效,具体原因不明)

看来要另外寻找代替此插件的插件鸟,在WP后台的插件安装那里搜来搜去,试用了好几个插件都不满意——不是功能不够就是太老兼容问题

好吧,用google搜吧,中文下没有结果(CP真厉害,到处一样),那就英文吧,搜……搜……搜……

》终于让我找到鸟:Disable Revisions and Autosave ,没有提交WP官方,难怪WP后台死活都搜不到。

PS: 很多好东东不一定在WordPress官网才能搜到,很多牛人就是很低调。

》和我一样懒的修改WP源文件的人就下载吧:disable-revisions-and-autosave.zip

》如果要单一功能就下载你需要的功能:disable-autosave.zip / disable-revisions.zip

》安装:WP后台-》插件-》添加插件-》上传文件 / 或者直接上传解压到 wp-content/plugins 即可。

》用法:激活此插件即可!

》当然你可以学我一样把插件代码扔进主题 functions.php 里面,效果一样。貌似没效!!!)

另外附个方法:如果你的WP已经生成很多修订版本,那么可以登录phpmyadmin,用下面的SQL语句删除全部修订版本(注意:操作数据库前先做好备份)

delete from wp_posts where post_type ='revision';

如果怕直接操作数据库,那么可以用插件:WP-Optimize,可以删除修订版本、垃圾评论、优化数据库。

写这篇文章(25259)时WP已经生成3个修订版本(25260、25261、25262),所以我的下一篇文章的ID应该是25263!

zww
or
oooo

“WP插件: Disable Revisions and Autosave”有184条评论

  1. 久酷 says:

    大叔换下地址栏显示吧,不要用ID了,用name

    1. zwwooooo says:

      @久酷 这……name都是中文……看起来很囧~而且收录都是id

  2. 风小 says:

    虽然对ID跳动很无奈,但至今还未找到好办法

    1. zwwooooo says:

      @风小 这个插件不行么?我用的很好

  3. zhy says:

    怎么看ID呢?
    话说我用Delete Revision,修订多了我就删除,指不定哪天要用那些修订版

    1. zwwooooo says:

      @zhy 如果你是用slug那么就不用在意了,看id可在修改文章的链接里面看到

  4. 赵福安 says:

    原来是日志id连着的插件,还是不需要了。WP-Optimize倒是刚合胃口。 :razz:

    1. zwwooooo says:

      @赵福安 应该叫屏蔽自动保存和修订版本功能的插件

  5. 福安 says:

    有没免费的空间,我想学建站

    1. zwwooooo says:

      @福安 免费的?现在很难找到好的

  6. 还有那些插件好啊

    1. zwwooooo says:

      @易赛快充营业系统 很多个人根据自己需求安装

  7. via says:

    何必纠结ID连续呢

    1. zwwooooo says:

      @via 有些人纠结,不纠结最好

  8. 正是我需要的插件,呵呵,踏破铁鞋啊

  9. oalleno says:

    其实我最想要的是可以直接修改ID的插件(已装的插件有部分重复的功能,只是还会跳ID),以前看到过一个,可惜没记下来,现在想起来很有用。。

    1. zwwooooo says:

      @oalleno
      直接操作数据库吧,不过风险大

  10. 剑书 says:

    话说WP-Optimize只支持到2.92,对数据库的操作适用于3.01么

    1. zwwooooo says:

      @剑书
      3.0.1后我一直用着,正常

    2. 剑书 says:

      @zwwooooo

      THX,用上!

  11. [...] disable revisions and autosave 目前没有收录到WordPress官网中。由ZWW推荐。(本博客采用) Super [...]

发表评论

昵称 *

网址

B em del U Link Code Quote