2010年10月12日 160条评论

Firefox每打开一个网站就假死一下的原因

最近我在 W7 使用 Firefox 遇到了一个非常让人恼火和纠结的问题。

表现

每打开一个网站就假死5~7秒!  如果同时打开多个网站那是10几秒不能动蛋!

XP 下的 Firefxo 没有此问题,上个月头 W7 下也没有问题。

尝试查找原因

我期间重装了 Firefox 两次,同样卡你没商量。

没装任何插件也试过 ,一样无法解决。

乱猜疑

1. 曾经怀疑过是用来升级系统的 360 安全卫士搞的鬼,但非常失望,不是!

2. 怀疑 Windows7 的系统问题 ,但不管我怎么查毒、查木马都没有什么发现,检测系统也没发现什么问题!

3. 胡思乱想:我的 RPWT!

无奈

暂时放弃 Firefox ,转主用 Chrome,但还是不耐用,于是前几天拜托 A-shun 定制一个 Opera 10.70 用(前天的文章已经说过,这里再感谢下)

爆发

昨天我要折腾主题,调试主题非 Firefox 莫属!调试了半个小时主题,我终于忍不住了,我要发疯了,不找出原因誓不罢休!

疯狂查找原因

1. 疯狂搜索,没有结果

2.  疯狂xx,疯了。

暴风雨后的冷静

狂吼后冷静下来,喝杯茶,突然脑经灵光一闪,一打开网站就卡,是不是 DNS 的问题?其他浏览器没问题那么就是 FF 本身的 DNS 问题了?本身的 DNS 影响最大的就是代理服务器设置问题,我的妈啊,竟然没去看过 FF 的代理服务器设置!!!

如下图

没问题啊,默认设置,不过跟系统设置 一致就是跟ie的一样了,于是打开ie的代理服务器设置,一看吓一跳,问题水落石出!

原来是我前段时间用了一段时间 Chrome 造成的,众所周知 Chrome 是通过修改 ie 代理设置实现代理的,而我用了自动代理插件,所以导致修改了ie代理服务器的自动代理脚本。囧~

解决办法

看下图吧,唉,低级错误~

郁闷了我大半个月,我撞墙去~

zww
or
oooo

“Firefox每打开一个网站就假死一下的原因”有160条评论

  1. 以前用vista的时候遇到过还以为中毒了,win7没任何问题~ :mrgreen:

    1. zwwooooo says:

      @一夜雨天
      呵呵,其实是chrome改变ie的设置导致的

  2. Lazyyyyyy says:

    遇到这些情况还真恼火,还好最后还是找出问题啦~

    1. zwwooooo says:

      @Lazyyyyyy
      郁闷了我大半个月

  3. 包子 says:

    ie的代理莫名其妙的就打开了

    1. zwwooooo says:

      @包子
      厄~ie很少用,chrome打开的

  4. Bee君 says:

    不过FF用起来没有Chrome这么顺畅~

    1. zwwooooo says:

      @Bee君
      平时使用就是,如果制作网站就FF给力

  5. 1杨董 says:

    还没遇到这种情况 给你点广告了

  6. 本来我很高兴,原来你说的是这问题啊,我这里还是卡,打开本地的网页就卡死。

    1. zwwooooo says:

      @IT不倒翁
      。。。本地是指哪里?

  7. 囧啊囧 says:

    我的问题和你的不一样,不过升级了不卡了,原因不明也不去追问了

    1. zwwooooo says:

      @囧啊囧
      不卡就算了,哈哈

  8. Louis Han says:

    我也遇到了卡顿问题 但不知道是什么原因造成的

    1. zwwooooo says:

      @Louis Han
      和我的原因不一样?

  9. 9hills says:

    嗯。。。我也是因为ff4卡的要死,,然后google一下。。就发现这篇文章了,还真是chrome的原因啊

    1. zwwooooo says:

      @9hills
      我想肯定很多使用chrome的人说ff4卡都是这个原因造成的

  10. renkai says:

    我用ff4也卡,但是实在linux里,没有ie的啊,而且

    测试地址:http://ie.microsoft.com/testdrive/performance/SantasWorkshop/
    测试的时候每分钟只有五个小精灵

    1. zwwooooo says:

      @renkai
      呵呵,那就不知道了,慢慢找原因,一款优秀的浏览器不可能还没怎么工作就卡的。

  11. coldplains says:

    来学习了~~~~默认表情表呀 不给里 :cry:

    1. zwwooooo says:

      @coldplains
      其实我的表情是动态的默认表情哦

    2. coldplains says:

      @zwwooooo
      就是因为原版默认主题 才不好看嘛~~~

    3. zwwooooo says:

      @coldplains
      霍霍,每个人的需求不同,我喜欢简单点又有趣点,这小表情可花了我不少时间做出来的。

  12. 我的一直是设置代理 。。。 :mrgreen:

    1. zwwooooo says:

      @荒野无灯
      唉,以前多好啊

  13. 沿见 says:

    悲剧啊,悲剧啊,我也是,终于找出问题了!谢谢拉!!

    1. zwwooooo says:

      @沿见
      霍霍,当时我也困扰了一段时间

  14. [...] 然后,重装Firefox,问题依旧;怀疑由于F支持GPU加速,可能是显卡驱动的原因,重装显卡驱动,问题依旧。终于想放弃换成Chrome的时候,在网上看见有人说,由于在用Chrome的时候在IE里设置了代理造成的。见下图: [...]

  15. Alex says:

    妈呀,终于解决大问题了!!因为用了Autoprxy,从来没注意过ff4的代理问题。
    太感谢了,我转一个链接走
    再次感谢

    1. zwwooooo says:

      @Alex
      解决就好

  16. Swing says:

    谢谢,困扰了我好久的问题终于解决了,刚从chrome转投FF不久~
    广告帮点了~

    1. zwwooooo says:

      @Swing
      能解决就好

  17. 谢谢 says:

    大哥,我也这样的问题 折腾死人....刚准备从5返回4了...还好搜到这文了

    1. zwwooooo says:

      @谢谢
      chrome无意中给了ff一招

  18. SunQH says:

    果真是这个样子啊,改过了之后就好了,多谢博主~

    1. zwwooooo says:

      @SunQH
      这不是bug,所以很难发现

  19. xq says:

    和你完全一样的问题,只不过我用的是goagent~自动修改了ie代理
    都快疯了,顺利解决
    谢谢

    1. zwwooooo says:

      @xq
      有时小问题会让人纠结很久

  20. normal says:

    额。我的也有这个问题。。不过我现在还是用Chrome了。用扩展+goagent实现代理功能。

回复给 zwwooooo ¬
取消回复

昵称 *

网址

B em del U Link Code Quote